ASP.NET SmartPart AJAX


I have installed .NET Framework 3.5 on our internal sharepoint intranet. Everything seems to be working fine except the cool SmartPart Ajax WebPart.
What’s the problem: The assembly "ReturnOfSmartPart" referenced to assembly System.Web.Extensions version 1.0.61025.0 but the new assembly shipped with .NET Framework 3.5 has the version 3.5.0.0.
 
Don’t panic, don’t uninstall .NET framework 3.5, just install the AJAX assemblies from version 1.0.
Since the GAC (Global Assembly Cache) allows you to host multiple versions of assemblies with the same name, you are safe. Make sure all you references in the web.config are pointing to 1.0.61025.0
 
OpenSource is sometimes very usefull, but in such cases as this, you are dependant on the goodwill of others…
Advertisements
This entry was posted in .NET 3.5 - ASP.NET AJAX SmartPart. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s