Migrate SharePoint 2007 to 2010 – Issues (1)


Issue : Missing server file or server configuration issues
Server side files are referenced in the content databases, but are not installed on the server. Without these files, the sites may not function completely or the content may not render correctly. Also, upgrade or post upgrade issues may occur if these files are not available in the new version environment.The following setup file(s) are referenced by the content, but they are not installed on the web server

  • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\Features\MapsWebPart\MapsWebPart\MapsWebPart.webpart], Reference = [1], Status = [Missing]
  • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\Features\MapsWebPartCSS\MapsWebPartCSS\mapswebpart.css], Reference = [1], Status = [Missing]
 
The solution pack was already deleted.
check the following libraries:
 
Don’t forget to empty your recycle bin!! it’s stupid but the reference will stay in your ContentDB 🙂
A preupgradescan will find them 😉
 
Here are some usefull queries which helps me to clean up…
 

SELECT

 * FROM Features WHERE (FeatureId = ‘guid’)

SELECT * FROM WebPartLists WHERE tp_DisplayName like ‘%webpartname%’

SELECT

* FROM AllDocs WHERE LeafName like ‘%webpartname%’

Advertisements
This entry was posted in Sharepoint. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s